Game Crashing Report Below

  • ToastyNetworks - Launcher

    Hi Guest!
    Are you using the brand new ToastyNetworks launcher yet? No? What are you waiting for! Enjoy a tweaked launcher made to make life easier for you! It includes pre-installed tweaks, fixes, texture packs and way more!
    Read more about it here.

Colinb17

New Member
Jan 14, 2019
7
0
1
51
#1
Game Crash report, game wont start keeps coming up with Error Code -1, any ideas on how to resolve.


---- Minecraft Crash Report ----
// I just don't know what went wrong :(

Time: 17/01/19 13:30
Description: Initializing game

org.lwjgl.LWJGLException: Pixel format not accelerated
at org.lwjgl.opengl.WindowsPeerInfo.nChoosePixelFormat(Native Method)
at org.lwjgl.opengl.WindowsPeerInfo.choosePixelFormat(WindowsPeerInfo.java:52)
at org.lwjgl.opengl.WindowsDisplay.createWindow(WindowsDisplay.java:252)
at org.lwjgl.opengl.Display.createWindow(Display.java:306)
at org.lwjgl.opengl.Display.create(Display.java:848)
at org.lwjgl.opengl.Display.create(Display.java:757)
at org.lwjgl.opengl.Display.create(Display.java:739)
at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:452)
at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:878)
at net.minecraft.client.main.Main.main(SourceFile:148)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)
at net.minecraft.launchwrapper.Launch.main(Launch.java:28)


A detailed walkthrough of the error, its code path and all known details is as follows:
---------------------------------------------------------------------------------------

-- Head --
Stacktrace:
at org.lwjgl.opengl.WindowsPeerInfo.nChoosePixelFormat(Native Method)
at org.lwjgl.opengl.WindowsPeerInfo.choosePixelFormat(WindowsPeerInfo.java:52)
at org.lwjgl.opengl.WindowsDisplay.createWindow(WindowsDisplay.java:252)
at org.lwjgl.opengl.Display.createWindow(Display.java:306)
at org.lwjgl.opengl.Display.create(Display.java:848)
at org.lwjgl.opengl.Display.create(Display.java:757)
at org.lwjgl.opengl.Display.create(Display.java:739)
at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:452)

-- Initialization --
Details:
Stacktrace:
at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:878)
at net.minecraft.client.main.Main.main(SourceFile:148)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)
at net.minecraft.launchwrapper.Launch.main(Launch.java:28)

-- System Details --
Details:
Minecraft Version: 1.7.10
Operating System: Windows 10 (amd64) version 10.0
Java Version: 1.8.0_201, Oracle Corporation
Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
Memory: 923842000 bytes (881 MB) / 1162870784 bytes (1109 MB) up to 3817865216 bytes (3641 MB)
JVM Flags: 4 total; -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump -Xms1024M -Xmx4096M -XX:MaxPermSize=256M
AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
FML:
Launched Version: 1.7.10
LWJGL: 2.9.1
OpenGL: ~~ERROR~~ RuntimeException: No OpenGL context found in the current thread.
GL Caps:
Is Modded: Definitely; Client brand changed to 'fml,forge'
Type: Client (map_client.txt)
Resource Packs: []
Current Language: ~~ERROR~~ NullPointerException: null
Profiler Position: N/A (disabled)
Vec3 Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
Anisotropic Filtering: Off (1)
 

Jijuihin

Senior Moderator
Senior Moderator
Staff
Requiem
Oculus
Iris
King
Jijuihin
Jijuihin
poseidon
Jan 8, 2017
213
24
18
#2
Hi there, would it be possible for you to try updating your graphics card drivers and then test this again?
 

Colinb17

New Member
Jan 14, 2019
7
0
1
51
#3
its on a laptop, ive uninstalled the drivers for graphics and reinstalled them still getting same message.
 
Last edited:

Oblitus_Est_Unum

L33T
L33T
Skurblord
Skurblord
nemesis
Feb 17, 2017
136
7
18
22
#4
To add to what Jiju said, LWJGL is not finding an OpenGL context. This often caused by not installing your Graphics driver or having a corrupted installation of said drivers. Let me know if you need help finding the right drivers for your PC.
 

Colinb17

New Member
Jan 14, 2019
7
0
1
51
#5
To add to what Jiju said, LWJGL is not finding an OpenGL context. This often caused by not installing your Graphics driver or having a corrupted installation of said drivers. Let me know if you need help finding the right drivers for your PC.

It’s a Samsung rv511 laptop with intel cpu n chipset n drivers, I did OpenGL checker and all seemed fine bar FPS being a bit low but was still over 200fps for a intel i5 with 8gb mem n 500gb hard drive.
 

Oblitus_Est_Unum

L33T
L33T
Skurblord
Skurblord
nemesis
Feb 17, 2017
136
7
18
22
#6
Okay. Looking at the spec page you should be installing some Nvidia drivers aswell. You should have an Nvidia Geforce 315M GPU. You can download the drivers from here: www.nvidia.com

Try installing that, rebooting. Then running the game. If it still fails you will need to open the nvidia control panel by right clicking the desktop and going to the manage 3D applications menu. From there add javaw.exe from your java installation. (Probably in the program files directory). Then on the Javaw.exe profile select it to run in "High Performance" mode. Then try again and see if it launches. Best of luck.
 

Colinb17

New Member
Jan 14, 2019
7
0
1
51
#7
tried both manual download of drivers for Nvidia 315M and did the Auto search from Nvidia too, both say no Nvidia. ive downloaded JavaW and run it with no joy still getting the code -1


Untitled.png Untitled-1.png
 

Oblitus_Est_Unum

L33T
L33T
Skurblord
Skurblord
nemesis
Feb 17, 2017
136
7
18
22
#8
Okay. Can you look on the bottom of the laptop and see if there is anything after the rv511. Would be something like (S01) for example. A serial number would also tell me what I need to know. There is apparently several different models for your laptop.
 

Oblitus_Est_Unum

L33T
L33T
Skurblord
Skurblord
nemesis
Feb 17, 2017
136
7
18
22
#10
Do you have anything plugged into the laptop while trying to launch the game? For example a joystick, game controller, or headset? If so try unplugging them and relaunching. Which launcher are you using? Try launching a vanilla MC game to see if its profile specific as well.
 

Colinb17

New Member
Jan 14, 2019
7
0
1
51
#11
only thing pluged in is a usb mouse, unplugged that, restarted laptop, ran Forge Vanilla 1.8.9, same result Untitled-2.png
 

Colinb17

New Member
Jan 14, 2019
7
0
1
51
#12
Done the ultimate, scrapped windows 10, and gone back to Windows7 on my laptop and it’s running A Ok.
 

Oblitus_Est_Unum

L33T
L33T
Skurblord
Skurblord
nemesis
Feb 17, 2017
136
7
18
22
#13
Glad you were able to figure it out. Hopefully it keeps working.